In order to run Warriors of Waterdeep smoothly, Android devices require the following:
Android version 5.1 and up
OpenGL 2.0 and up